MEF Module and Data Services

Nov 6, 2009 at 7:38 AM

I have an application with 2 SL modules (Shell and Customers), and a Web Server application plus a Data Service, both in the server side.

The SL Customer module is connected to the Data Service. I modified the <LinkedServerProject> in the Customer csproj file to link the RIA framework with the Data Sevice project.


The diagram is:

Server Side                  Client Side
Web Server App <-> Shell
Data Service App <-> Customer module


At this point, the RIA generated code is correctly created in the Customer project, but when I execute the app, I get the exception "resource not found".

I think that the reason is that the Web Server App does not have the assemblies of Data Service App in the bin directory. Ok, I add a reference of Data Service App in the Web Server App. I compile and now I can see the Data Service App assembly in the BIN folder of the Web Server App. I run the application and now it works fine, only that the generated code in Customer module is empty. Now, the generated code of Data Service App is created in Shell project.

I am totally confused. Is there an example about to use modules with MEF , each module with its associated data service?


Thank you



Nov 6, 2009 at 5:04 PM

Perhaps I'm also confused but it doesn't even seem as though your application is using MEF at all. It seems like it is some issue with the Ria Data Services.

As far as a Ria Services sample that uses MEF I'm not sure I'm aware of any example that does what you are looking to do with MEF.