VS 2005

Oct 30, 2009 at 1:11 PM

Is there any chance that I can use MEF in a Visual Studio 2005 project?

I have tried, but there are some problems in building ComponentModel, most of them from the LazyService.cs file

Coordinator
Oct 30, 2009 at 3:43 PM

MEF uses a lot of LINQ functionality, so it requires .NET 3.5 (ie VS 2008).  You would have to modify it extensively to get it to work on .NET 2.0.

Thanks,
Daniel